New Posts New Posts RSS Feed: RAYMARINE - DSM 300
  FAQ FAQ  Forum Search   Register Register  Login Login

RAYMARINE - DSM 300

 Post Reply Post Reply
Author
bingo296 View Drop Down
Newbie
Newbie


Joined: 18 Jul 12
Online Status: Offline
Posts: 3
Post Options Post Options   Quote bingo296 Quote  Post ReplyReply Direct Link To This Post Topic: RAYMARINE - DSM 300
    Posted: 04 Oct 12 at 9:27am

I've been very unhappy with my Raymarine C-120 since the day I had it installed on my center console. I like the actual unit and how easy it is to use, but I've had constant problems with it.

While the sounder worked for a few weeks with little problem, things have gone down hill ever since. My radar sometimes doesn't even work. Lots of times it cuts out at the most important times leaving me in uncomfortable/dangerous positions.


The "DSM connection lost" alarm constantly goes off and my sounder does not work due to "no data source." I've heard all of the horror stories, done my research, played with the unit and owner's manual and have had no luck.


I can't afford to send the DSM back to the factory in the middle of the summer in fear of not getting it back for weeks. Atleast right now, sometimes my radar works.


I installed the latest and greatest software update and nothing has improved with my problems.


I used to lose my sounder pretty much only when starting my engines (understandable due to voltage issues) but now this no data source has got me really confused. The "DSM connection lost" alarm is quite irritating too. The status light on my DSM is orange (blinking) and sometimes straight green (inconsistantly).


I'm open to all ideas...thanks for any help in advance.



Edited by bingo296 - 04 Oct 12 at 9:28am
save the water
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

Bulletin Board Software by Web Wiz Forums® version 9.665y
Copyright ©2001-2010 Web Wiz